geteilt von: https://lemmit.online/post/3018791
This is an automated archive made by the Lemmit Bot.
The original was posted on /r/ProgrammerHumor by /u/polytopelover on 2024-05-26 21:23:20+00:00.
First one are method name, second one are status name.
def open_file_dialog(self): self.dialog_file_open = True pass
Yoda level preference war.
Lol mutable state
I tend to add is to booleans toreally differentiate between a method name and a status.
def open_file_dialog(self): self.dialog_file_is_open = True pass
That way, it’s easier for my dumb brain to spot which is which at a glance.
is_dialog_file_open
fite me
No fiting. IS always goes at the start of names for booleans you are correct
There is a reason why little endian is preferred in virtually 100% of cases: sorting. Mentally or lexicographically, having the most important piece of information first will allow the correct item be found the fastest, or allow it to be discounted/ignored the quickest.
That’s actually filtering not sorting.
That being said, it’s more valuable (to me) to be able to find all my things for a topic quickly rather than type.
Foo_dialog
Foo_action
Foo_map
Bar_dialog
Bar_action
Bar_map
Is superior IMHO.
If you are looking for
Bar
, it is highly likely that you are already looking specifically for a particular functionality - say, theaction
- forBar
. As such, it is irrelevant which method you use, both will get you to the function you need.Conversely, while it is likely you will want to look up all items that implement a particular functionality, it is much less likely you are going to ever need a complete listing of all functionality that an item employs; you will be targeting only one functionality for that item and will have that one functionality as the primary and concrete focus. Ergo, functionality comes first, followed by what item has that functionality.
We probably have slightly different work processes.
I’m more likely to be making “foo” functionally complete and then making “bar” complete than I am to be making all my dialogs functional then all my tabs/whatever.
This comes from TDD where I’m making a test pass for “foo”, once done, I’ll do the same for “bar”.
Though it’s even more likely these are different files entirely, rendering the arguments moot.
I put all those in different files
compont/functions/foo.ext etc.
Depends on the language’s constraints, but yes: more smaller files please!
But also, sorting big endian automatically groups elements associated with common functions making search, completions, and snippets easier (if you use them). I’m torn
I was going to write something like this. You actually wrote about semantic order, but syntactically it is as much important e.g. it is easier to sort dates such as 2024-05-27 than 27.05.2024 in chronological order.
I’m truly torn with this. The first one seems sensible (action -> target) and easier to read and reason about (especially with long names), while the other one looks more organized, naturally sortable and works great with any autocompletion system.
Not a programmer, but I’d prefer right naming convention because sorting
I am a programmer, and i also like the naming scheme on the right
Especially for things like filenames
Also a programmer and think method names would be conducive using little endian.
TopicGet() TopicCreate() TopicDelete()
Writing this I realize we do this implicitly in some instances.
http.Get() -> httpGet() http.Post() -> httpPost()
We need a new framework, one that allows universal lookup, and makes life easier
x = _.dialog.file.open y = _.open.file.dialog z = _.file.open.dialog a = _.file.dialog.open
Once done, the formatter simply changes everything to
_.open.file.dialog
Let’s get this done JS peeps
\s
Aahh you can’t just make this problem object oriented!
C programmers don’t like that.
Insert xkcd about 15th format
Where’s
file_dialogue_open
This is the real big-endian way. So your things line-up when you have all of these:
file_dialogue_open file_dialogue_close file_dropdown_open file_rename directory_remove
If I were designing a natural language, I’d put adjectives after the nouns, so you start with the important things first:
car big red
instead of
big red car
Heathen! You must alphabetize all the things!
Like seriously. It makes scanning code much easier.
To be fair, it’s also missing
open_dialog_file
,dialog_open_file
and most cruciallyfile_open_dialog
I prefer everything to be how you would read it as text. So
create_file_dialog
it is. Honorable mention is to have it namespaced in a class or something which I think is best.file_dialog.create
ordialog.create_file
or evendialog.file.create
My method names are the same way but I aggressively sort things into modules etc so it comes out the other way.
But if I was staring down dozens of these methods and no way to organize them, I’d start doing the sorted names just for ease of editing. L
I agree. I say open door so the function should be named
openDoor
.Honestly nowadays none of that matter if you’re using any remotely modern IDE with good indexing and a sensible search, you can start typing however you mind works and it will find it no matter how it’s named.
I do one, the other senior dev does the other. We fight about it in pull requests.
Your team needs to have a coding standards meeting where you can describe the pros and cons of each approach. You guys shouldn’t be wasting time during PR reviews on the same argument. When that happens to me, it just feels like such a waste of time.
Preachin to the choir, friend. I’d get worked up about it but I’m paid the same regardless of how upset I get.
Or they need to kit car about stuff like this since it probably doesn’t actually matter.
Agreed. This type of fun is good for the team. Trying to stamp it out, when it impacts very little, is just a buzzkill to the team.
This sounds like the typical plot of a story from The Codeless Code.
Edit: How about this story specifically?
deleted by creator
US Army logistics catalogs are organized this way. “Cookies, oatmeal” instead of “Oatmeal cookies” because it’s a lot easier to find what you need an a giant alphabetical list.
deleted by creator
How any large organization gets away with not using YYYY-MM-DD format is beyond me.
Taking over some of my previous directors files is like chaos.
How anybody publishing entire internet memos without a date being on the first page is beyond me. Like wtf am I reading a PDF from 15 years ago or last month?
Variety is the spice of life.
Mmmmmmmm… Lexicographical Endianness.
the people who chose the first one…who hurt you?
I will
No one, it just makes sense.
You must be one of those “Throw your mother downstairs, the box of tissues” types.
Yoda sounded normal to you I bet.
It makes sense until you write 30 methods to manipulate the data layer.
Fuzzy search solves this pretty good
reverse polish notation time
Powershell
I used to like the
action
followed bydirect object
format, until some time ago when trying to find methods or variables related to a specific object. If the action comes first, scanning for the object without an IDE means first reading unnecessary information about the action. That convinced me to opt for$object-$action
in situations where it makes sense.For example in CSS, I often scan for the element, then the action, so
$element-$action
makes more sense. BEM kinda follows this. When dealing with the DOM in JS, that makes sense toobutton.fileDialogOpen()
,button.fileDialogSend()
, … makes more sense when searching.Of course one has to use it sensibly and where necessary. If you are writing a code that focuses more on actions than objects, putting the action first makes sense.
A similar thing is definition order.
def main(args): result = do_something(args.input) processed = process_result(result) transformed = transform_object(processed) return transformed.field def do_something(some_input): ... def process_result(result): ... def transform_object(obj): ...
I find this much easier to follow than if
main
were defined last, becausemain
is obviously the most important method and everything else is used by it. A flattened dependency tree is how these definitions make sense to me or how I would read them as newbie to a codebase.I agree with you especially on the definition order of functions. I, too, define
main()
first.
Be php, mix and match
let the chaos reign
First of all, it’s spelled dialogue
Two wars can exist simultaneously.
OP’s username is in German, so it’s probably half-German-English code
Germans learn UK English
Dialogue is UK English. But I just looked it up and apparently ‘dialog’ is a computer term, but should not be used on its own but rather in combination, such as ‘dialog box’.
Americans sadly got there first and defined all the computer terms, that’s why it’s a TV programme but a computer program. I can deal with that though, helps distinguish computer things from real things!
I worked at a place where all the DB column names were like
id_user
,id_project
. I hated it.I didn’t really care about this thread until I read this comment.
I worked on one where the columns were datanasename_tablename_column
They said it makes things “less confusing”
Powershell has a lint warning for functions that don’t follow Verb-Noun format, and verbs here are a list of approved verbs lol