“result” is fine. That is the variable you will end up returning that you have to fill with stuff first.
“data” on the other hand…
I came here to say this.
Declare
result
in the first line of the function andreturn result
is the last line. In C++, this is a big hint to the compiler that you want return value optimization to kick in.
As a person who victimizes coworkers like this, I apologize. Thank you for pointing it out, and I will stop doing it.
Be proud that it’s a step up from var x
Be scared that your coworkers are planning how to best apply the baseball bat to your knees anyway
Even using absolute best prackies, developers are gonna find a bunch of stuff to complain about.
Well obviously it’s the result of some algorithm that will happen.
function algorithm(input)
Will name every of my functions like this now, thank you for pointing out that incredible meaningful name
I’ve had instances where I worked with an API so badly designed in a dynamic language that I had no idea what I might receive.
This, when I get something back that’s not what I expected, I just logged the type because I really don’t know what it is. It’s the result. Whatever that means.
It could be that this is a habit left over from pascal, where result is a reserved word, and is automatically made the return value of the function.
If it is in the context of a short function, I don’t see that it’s all that bad.
Yup, I also do that. If I just need a variable to put in what will be returned, I call it
result
. What it means should be clear from the function name. Repeating that feels redundant.
I’m good with this in C#
Exactly. If it’s a statically typed language and the function has a clear name? I know what type it is, I know what it’s for, I’m good.
There are far worse sins, like intermediate variables or worse, public class members named “obj” or “data”.
deleted by creator
GitHub doesn’t show types. So if the value is given to another function you would have no way of knowing what type it is unless you read the file that other function is declared in.
As someone who uses ‘result’ as a variable name in functions all the time, please tell me what you think is wrong with it?
If a function is called for example ‘transformAtoB’ it should be totally obvious what the variable will contain.
It’s not necessarily bad, it just provides very little information.
The only issue is “var”.
You declare it as the first line after “function getNextDay() : date {”, then it is glaringly obvious that is a date variable that will (eventually) contain tomorrow’s date, and will be returned by the function.
However, I would only use “var” if it’s initialized in the same statement. It prevents Smurf code, and the compiler knows the type straight away.
Given a small and clean context, variable names don’t need to be specific.
yah because we’d rather die than use return type hints.